Integration strapi by custom token is not working

I’m trying to link data with straapi.

Integration does not connect the multilingual languages already created in Strappy.

When I create custom token with i18n added in strapi token, I get 403 error when I log in

Hi Minsu,

To better assist you, could you please provide the exact steps you’re taking when setting up the integration and the point at which the 403 error occurs? Additionally, confirming the permissions assigned to the custom token you’ve created would be helpful.

As well, you may share the details via

I installed strapi on Crowdin, logged in, and then synced the strapi data, but even though the strapi has completely translated data, it does not come over to Crowdin and remains at 0%.

The 403 error occurs when you add a few translations in Crowdin and press sync in Crowdin.

This error occurs in upload api.
{“message”:“Request failed with status code 400”,“code”:500}

Thank you for reaching out. To address the 403 error and the issue with translations not syncing from Strapi to Crowdin, please ensure that the English language is added in the Strapi app settings within Crowdin.

If the problem persists, it might be necessary to check the permissions and the token type used for the integration. Please verify that the token has the correct access rights.

Should the issue continue after these checks, please provide us with any additional error messages or screenshots that could help us diagnose the problem further.

Strapi token has been granted full access token type.

I have also added language settings to the integration settings.

And the data exported from Strapi are loaded into Crowdin in xml format.

Can I get it in json format?

Currently, obtaining the content in JSON format is not possible. Could you please share the reason for the preference for JSON format? We’re using webxml format for having a preview of the content in the Editor

Checked it.
It doesn’t matter what format it is.
Data translated from straapi is not being imported to crowdin normally.

In addition, 500 error occurs when I try to sync to straapi after translating from Crowdin after integration.

Dear Minsu, could you please kindly record the video of the case when you receive a 500 error with the browser console opened? And also please tell us the project name

Dear Minsu, thank you, passed it developers

Dear Minsu, we’ve created the task for our developers (CN-44465), once we have some news - we’ll let you know right away

Hi ! Could you please try again and let us know how it goes?

The data value does not cross when syncing from straapi to crowdin.

The same 400 error occurs when syncing from Crowdin to straapi.

The error is the same without any changes. you should also see in your logs the fields that cause the error. The thing is that on the Strapi side, the fields are created for the text while you have numbers there and Strapi API doesn’t work with that. As a workaround, we would recommend changing for example from 56 to 56cm (to have some text in the field). Then import that source again to Crowdin and later after uploading translated files back to Crowdin, there shouldn’t be any errors

@NataliaM Please share the progress.

When reading data from straapi, it is completed normally without errors, but the values do not come in.

When exporting translation data from Crowdin to straapi
api returns the error below.
{“message”:“Request failed with status code 400”,“code”:500}

Hi Minsu,

We are currently working on your request and will provide an update as soon as possible. Your patience is appreciated.

Hi ! this error means that the target language that you set up is the same as the source one. Please check the language mapping in the app settings

Is there any progress?

Did you check language mapping in the app settings?

Yes, I’ve also checked the language mapping.