Webflow integration not importing strings

Weve been using the webflow integration to import our strings from our website and it has been working fine, we have translations active, but currently whenever we try to update the strings using the integration we are losing our previous versions and it is importing everything again so we have no translations.

Weve tried reinstalling the integration module but it has no affect. We have four languages and an open education account.

Everything was working perfectly up until our recent account upgrade.

Any gelp would be greater appreciated.

I’ve found here the same question, so I assume fix should be somewhere on the way

Guys also saying that cache clean may help, have you tried?

I tried clearing cache, using incognito both and it still isn’t working

My instance seems to works fine. But I also had few issues with that and re-install within past 3 months maybe 5 or 6 times.

What helped me is clearing cache by hard browser restart. Maybe it deleted all cookies or some others hidden things. Also in my experience it’s more stable in Safari than let’s say Chrome or Edge.