Unity Plugin doesn't push tables

i have Unity plugin 7.0 (latest)
i connect fine to Crowd in but the push is giving me a BadRequest with
API Error: Key “storageId”: Code “notGreaterThan”: The input is not greater than ‘0’


Hi @blindspot,

Have you checked if you connected everything right?

Everything is connected. we use Localization package for a while and the Crowdin plugin worked before.
i updated to 7.0, removed some languages etc … nothing

It seams that the storageId is missing and the GetSourceFiles is empty event if i have file in my project

i have found the issue …
when creating a storage i get an ID and this ID is above the max value for an int32 and so the unity plugin does not deserialize it correctly.


public class StorageData
    public int id;
    public string fileName;


so i cannot use the plugin right and can you please provide a patch ?
Thank you

after replacing to a long everything work well …

Hi @blindspot ,

You mean that before updating the Unity plugin everything worked fine with long id values ​​but now in the latest version 7.0 if the value “storageId” exceeds the value then you get an error in the response, right?

No I mean in both version storageId is an int but the id generated on your backend are now above the max int value, so it’s not working.
Show this to you c# unity plugin dev he will understand I think.

Hi @blindspot ! checking on our side

@blindspot just wanted to let you know that we created a task (49052) for our team to check and fix this
will let you know once we have any updates

This is blocking production
We are experiencing the same issue, any idea when this will be fixed @Ira ?

Hi @JacobFunday ,

Sorry for the inconvenience! Our developers are still working on the case. As soon as we have an update, we’ll let you know.

Hello! I have the same issue with CrowdInAPI: when pushing files to Crowdin I get the error The input is not greater than ‘0’

2024-06-16 11:43:51,673 [ForkJoinPool.commonPool-worker-4] ERROR  - Invalid http response code received, received 400, response body:
2024-06-16 11:43:51,674 [ForkJoinPool.commonPool-worker-4] ERROR  - {"errors":[{"error":{"key":"storageId","errors":[{"code":"notGreaterThan","message":"The input is not greater than '0'"}]}}]}

Before it always worked well. The last successful synchronization was at 2024-06-12

Hi @avan !

Can you please tell us the name of the project where you have faced with such behaviour?

Thanks in advance!

Hi @Tania
my project is avan/unf_vi

Hello @avan :wave:t2:
Thank you for sharing - have passed it to our dev who works on the task. Once we have any updates, we’ll follow up in this thread!

Hi, please try updating to the latest version - 2.23.1. It already includes the fix.

Hi @blindspot @JacobFunday, the Crowdin Unity plugin issue is already fixed. Please try to update to the latest version (0.7.1). Sorry for the inconvenience!

Hi @andrii-bodnar !
unfortunately, I can not update my synchronization tool
Is there any way to change StorageId for my project so it could be int again?

@avan unfortunately no, that’s not possible. The storage ID has reached the int limit so now it’s bigger and can’t fit in that data type.