[Solved] Whitespace (newlines) in translations no longer consistent


It used to be that the Crowdin interface warned the translator if their proposed translation had (or didn’t have) a newline where the source text didn’t have (or had) a newline.

This seems to have disappeared. Is there a setting to bring it back? It’s causing corruption of my translations.

I’m using GNU Gettext PO files for translation.

The issue is mentioned in the Gettext FAQ, so I think it’s important that this warning is present, or the translated string fixed automatically: GNU gettext FAQ

I have found the setting, it is under QA Checks → Spaces mismatch.

Problem solved.

1 Like

Great to hear this :slight_smile:

You’re also welcome to check this article, it contains a lot of useful information about the Editor.

The settings doesn’t seem to apply to trailing new lines. Is this on purpose? And is there any way to warn about additional line breaks that were added to the end of the string by accident?

Hi Zenkit,

In Crowdin Enterprize we have custom QA checks that allow to check the newlines consistency NewLine Harmony - Crowdin Marketplace

Please note that this feature is not supported in crowdin.com

Hi Olena,

Thanks for the quick response. Migrating the translations to a new account and paying almost four times as much as before, just to get this feature, seems a bit much though.

Is there any other way to get this to work? Maybe the “Spaces mismatch” setting could be adjusted to also apply to line breaks?


Hi Jesse,

Thank you for your suggestion,

I passed on this improvement request to the Product team and they informed me that adding the custom QA checks for crowdin.com is not on our roadmap. Hope this will be re-considered in the future :crossed_fingers:t2::blush: