[solved] Integration is not creating new commits and PR


for an unknown reason the GitHub integration is not pushing new commits to branch (thus not creating the PR).
I deleted the branch, and forced a synchronization, the branch has been recreated, no new commits pushed to it, beside me having fixed a string.

Is this a known issue?

Hi @kumy !
Could you please try to Pause/Resume integration and Sync Now?

Hi @Olenka
Sure, I just pause, wait 5 seconds then resumed, the sync started by itself, let’s see if it works.
PS: I already pause/resume before reaching here

I worked! Thanks
Did you do something on your side?

And BTW, is there a way to push all changes in only one commit to save CI jobs from running for each commit?

Happy to hear that it works :slight_smile: We didn’t do anything from our side, seems the system was stuck.

It is necessary to choose “Squash and merge” when you do the merge and it will decrease the number of commits


hum, whatever merge strategy you chose, that will trigger only one CI trigger.

I was talking about the 5 commits that were pushed sequentially, that will trigger CI when each of them arrive. (I circumvented it by implementing some logic in my CI to completely skip them, but I would have preferred receiving only one big commit and launching the CI). I didn’t saw any option for that, so maybe it could be a good candidate for a Feature Request :angel:

Here they were having the same issue as me and they chose the same approach

Dear @kumy ,

It is the only possible way to reduce the number of commits. There isn’t a possibility to have one big commit. Sorry to say this!