Retrieving a list of projects API endpoint returning error


We are trying to migrate from API v1 to v2.

We are using a shell script and curl to access the API and we did manage to get results for api/v2/user so the token seems fine.

However we are encountering an issue when trying to retrieve a list of projects via the api/v2/projects endpoint. We are getting the following error message:
{“error”:{“message”:“Endpoint isn’t allowed for token scopes.”,“code”:403}}

We get the same error if we try to add a new project. We tried to search through the documentation but we didn’t find any answers.
Can someone point us in the right direction?



It might be that you can’t list projects because you don’t have any projects created yet or don’t have enough rights as the error asks you to update scopes in order to retrieve the action.
As for the add project, the reason might be that you don’t have enough rights to add the project or your subscription doesn’t allow you to have a private project

Thanks! That was indeed the problem, we were missing some rights.