Problems with OpenAI pretranslation

I have everything configured properly. The translation consumes money from my OpenAI Api account, but unfortunately after some waiting I get a message that all phrases were skipped because of AI error

hi @d.lisiakiewicz ! Could you please let us know which provider and model are you using for the pre-translation? Is it successful for all target languages or just for some? To better assist you, could you please provide any error messages you’re receiving?

Thanks,

Here are my settings:

MODEL GPT-4
Error message:
AI error

My settings:

Hi @d.lisiakiewicz ,

Could you please share the link to your project, or the project identifier? Project identifier you can just copy from project url and just share with us so we can check everything from our side by project logs

Hello, here is the project ID: 662040
Water-display dashboard in Crowdin

Hi @d.lisiakiewicz,

Thanks! As far as I can see, the .docx file in the project was completely successfully translated using Pre-translation via AI. So from what I understand the pre-translation was broken when trying to translate a .po file that contains a lot of tags, am I right?

I see some logs related to this, already passed it on to the development team. As soon as we have updates, we’ll let you know right away!

Hope for your understanding and patience

Yes this is correct. We had problems with pre-translating both files (.dox and .po) and also using both GPT 3.5 and 4. The results were the same: all phrases ignored. Finally we managed to translate the .docx file with GPT 3.5 after several trials.

Hi @d.lisiakiewicz thanks for the additional info! As far as I can see, our developers are working on this case (46714) so we will let you know once we find something or have any updates on this

Hi! Coming with updates, the issue with AI pre-translate has been fixed and should work fine now.

Hello Dima, thank you for your return. I tried once again but still no success. Here is the result:

Hi @d.lisiakiewicz,

I can see from our side the logs about time-out and exceeded limits. Did you try pre-translating all files at once or specific file only? Perhaps you could try to do it per file and language?

Looking forward to hearing from you,

Hello Tania, It looks that it was not working earlier today because I ran out of budget on OpenIA. I am checking this again and it seems to be working. Please give me more time.

@d.lisiakiewicz ,

Sure, feel free to test everything and let us know how it works :slight_smile:

Hello I am still having the problem. Please check the logs for the last translation od po (2).po file.
I see on OpenAI that the tokens are consumed but in summary on your site I get the same message that all phrases are ignored.

@d.lisiakiewicz ,

Sorry for the inconvenience! Did you run pre-translation for all languages or specific ones?

I ran the translation from English to Polish.
Only one language, only one file. ~400 strings.