Pre-translation via AI doesn't work

Pre-translation via AI skips all the strings and doesn’t pre-translate the text. What should I do?

From my side, I see that due to long strings in your files, the answer from AI (via the pre-translation request) has been generating for too long, which is why pre-translation was skipped

I’d suggest you split the file or the request (for example, run pre-translation for 1 language only)

In case you will need a more detailed consultation please reach us directly at

My file was approximately 800 strings, I split it into 3.
So I’ve uploaded 3 files which have 267 strings in each.
Then I tried to pre-translate via AI again, this time I selected only 1 file and 1 language.
It didn’t work.
Could this problem be because I’ve uploaded an SRT file?

The issue you’re experiencing with pre-translation may not be directly related to the file type

However, to assist you further, could you please provide me with the SRT file sample you’ve uploaded?

Also, would you be able to double-check the API key you’ve used? The most recent logs of your projects show that the API key is invalid

WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free. this is the file.
And I’ve recreated the api key and tried again but still there’s no result

Hi @egmnshnky ,

Thanks for the details! I can see the following message in our logs: You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs:

Could you please check everything on the OpenAI side and get back to us?

Still the same problem


Did you check the logs and your quota on the OpenAI side? Also, would you please check if your API key is valid?

I think this problem is caused because of my rate limits in openai.
Right now my account is seen as tier 1.
So, do you know what tier I should be to get a translation between 800-1000 strings? I will load money and buy credit accordingly.

Hi @egmnshnky !

We noticed from the logs on our side that the incorrect API key provided. You can find your API key at

Please check this from your side to make that you are using the correct API key!

The Problem was coming from openai side, I didn’t have enough budget, so, I’ve uploaded 50 dollars (that’s what it takes to move on tier 2) , then it worked