MS words a lot of tags in editor

I uploaded MS Word file into Crowdin, in editor it shows enormous amount of tags. I search for a solution here in Crowdin community, found few topic, and I used the suggestion from them, I enabled hide html tags in editor Settings but it solves the issue only patrially. A lot of tags still exists. Its not friendly for translators. How can I solve this?

This is a “special feature” of this file format, we can’t totally remove those tags from Word files.

Still, we added a new feature recently, Clean tags aggressively, which should remove most of them from the Editor. It’s in the files → file settings → parser configuration. Would be needed to re-import the file once it’s changed.