JSON HTML Integration failing on certian files

I am trying to use the JSON HTML integration which is working well on some files but failing with an unhelpful error on others which prevent the file from being imported.

These are all standard JSON files in the same format as the ones that work but they fail to import with the following error:


Example file that works:

  1. https://gitlab.com/cyberpunk-red-team/fvtt-cyberpunk-red-core/-/raw/hotfix-0.88.3/src/babele/en/cyberpunk-red-core.core_gear.json

Example file that does not work:

  1. https://gitlab.com/cyberpunk-red-team/fvtt-cyberpunk-red-core/-/raw/hotfix-0.88.3/src/babele/en/cyberpunk-red-core.black-chrome_gear.json

The errors are not limited to this file and effect 8 of the files in my project but apparently new forum users can only have 2 links in their post. All files are valid JSON and all contain valid HTML in the description keys as far as I can tell.

I’m currently working in a test project before using this in the main project, you can find the test project here: crowdin com / project/testy-mctesterson

Hi @Twiglet ,

Thanks for all the details! We will check everything from our side and get back to you with an update.


Just a quick follow-up on the matter :slight_smile:

It seems the reason here is in the subscript in the keys (e.g. “CO₂ Tank”). Is there any chance you could remove subscripts from the keys of the file and try to import the file again?

Hi @TaniaM

Just tested with the replaced with a 2 and it worked. Thanks for your help!

Given is a valid utf character I would expect it to work (along with other valid characters). Is there any way to raise this as a bug?

Just as an FYI this seems to also fail on characters like ™️ and ©️.


Happy to hear it worked! I will also create a task for our developers to change this behavior, of course :slight_smile:

1 Like


Thanks again for your help with the previous issues. I have fixed the previous files that were failing by replacing/removing the unsupported characters and it has successfully imported those files.

Unfortunately the import process is still failing on a number of files with the following structure:

Hi @Twiglet ,

We have made some improvements to the app. Perhaps you could reinstall it and try uploading the files once more?

@TaniaM thanks for the quick reply. Unfortunately it’s still failing on any file with the structure mentioned above.


I have uninstalled and re-installed the plug-in as requested but it’s still failing. I do notice on the plug-in page that the “Updated” date still states May 17th

@Twiglet thank you! will pass it to our developers.

Hi @TaniaM / @NataliaS,

Any update on this? Checking the plugin page it still lists May 17, 2023 as the last updated date.

If not can you advise on a way to only use the html-json plugin for certain files? Unfortunately it seems to apply to all json files so we’re stuck with either some files not working (the bug above) or not being able to use the plugin at all.


Dear Ryan,

I’m afraid we don’t have any news on the matter, but plugin should be improved soon.