[JS Proxy Integration] Failed to generate a distribution script. Please try again

I get the following error on a new project. Not sure if there is something wrong my project, or some service is on Crowdin’s end is just not running correctly at the moment.

Failed to generate a distribution script. Please try again

In the logs, it says:

Failed to create distribution.
Please try importing the website

Of course the website is already imported.

Checking the Translations page, I cleared all the target file bundles and over the air content delivery items, and tried again. It did create one item in each of these sections again, but it is unable to release it. Trying to release it myself also gives an error.

The server encountered an internal error and was unable to complete your request

Hi @ReenigneArcher !

Could you please kindly contact our support team via support@crowdin.com and specify the project name?

1 Like

Looking forward to your reply.

P.S. I have tried removing the integration, clearing browser cache, and then re-adding the integration. I get the same error.

It seems to be partially creating the release according the API logs.

But the release does not actually exist.

Please let me know if I can provide anything else to help solve the issue. Thanks!

Hi @ReenigneArcher ! We will definitely reach you back as soon as we have some updates regarding this case

1 Like

I’ve tried recreating the integration again… Now, I’m getting a new error.

Failed to scan the web page. Please make sure the web page is accessible and try again

Website is accessible and hosted on GitHub. https://app.lizardbyte.dev

Logs, show “Expected pattern to be non empty string”

These are my settings:

site url: app.lizardbyte.dev
separate files for each page: checked
page limit: 10000
ignore by IDs: n/a
ignore by css classes: crowdin-ignore
default page timeout: 0
language detect type: query parameter

Disabling in context preview allowed me to get passed this new error, but back to the original error.

I’ve now uninstalled the JS proxy integration, and going to try again in a few days or something, unless someone has some idea of what I can do.

Hello @ReenigneArcher
Thanks for your test and additional details, much appreciated. I’m sure this will speed up our investigation. Let’s hope we’ll find the answer soon :wink:

1 Like

Tried installing the js proxy tool again today. Same error after trying to setup the integration.

Hi @ReenigneArcher !
I’m so sorry to hear that reinstalling didn’t help. We have already passed all details to our devs and once we have any news from them, we will let you know :wink:

1 Like

Bump… checking for status update

Hi @ReenigneArcher !

Sorry, there are no updates yet as the tech team is pretty busy rn. But I will ping up them from our side.

Hope for your understanding and wish you a nice rest of the day :slight_smile:

1 Like

I know this is not an easy problem to solve, but is there any update? Could you get a developer to look at this?

Hi @ReenigneArcher,

Coming back to you,

Could you please try adding the links to the ‘Exclude paths’?

@Olena I’m not exactly sure what you are asking me to do, but I believe my settings are already like that as I indicated here: [JS Proxy Integration] Failed to generate a distribution script. Please try again - #7 by ReenigneArcher

I have followed the example provided.

Anyway, the strings seems to extract just fine and most terms have already been translated by our community. But the tool is not creating a distribution, so it’s unusable.

These logs are also not that helpful, or recent.

P.S. This project (LizardByte.github.io dashboard in Crowdin) with almost identical settings works fine, using the same source site. The only setting that is different is Separate files for each page is unchecked… but I want it to be checked in the new project.

Dear @ReenigneArcher , will pass that tovs and keep you updated

@NataliaM I received your email. It appears everything is working now! Thank you everyone involved in helping resolve this!

Dear @ReenigneArcher you’re always welcome :slight_smile: