How to prevent missing spaces in translated Yaml files

After the translation, the new translation yaml file was missing a space after the comment. How to solve such a problem.

-# abc


Hi @linkinstar-sf ! as far as I can see, you take part as a proofreader in the open project. Would it be possible to let us know what file from the project is having this issue? didn’t noticed the text like on your screenshot in the project

Thank for your reply. The project is Answer dashboard in Crowdin. You can see the problem here New Crowdin updates by fenbox · Pull Request #1 · fenbox/incubator-answer · GitHub

Hi @linkinstar-sf ! Could you please let us know if the same behavior persists once you are pushing the translated strings?

Here’s what I do: I submit the translation on crowdin and then sync it via github intergration. After the sync, crowdin submits a PR, which then looks like what you see here. So, I am not sure this operation whether you mentioned “pushing the translation strings”.

Hi @linkinstar-sf ! got it, checking on our side and will get back to you with the details

@Ira May I ask if a solution has been found?

Hi @linkinstar-sf ,

Our developers are currently investigating the issue you’ve reported. We understand the importance of this matter and have prioritized it accordingly. As soon as we have more information or a solution, we’ll be sure to update you.

Will keep you posted.

Thank you very much for your quick reply and help. I’ll wait patiently.

Hi @linkinstar-sf !
Could you please install the app
and specify the following custom code?
content = content.replace(/#/g, '# ');

@Ira Thanks for your help. However, it solves part of the problem, but brings new issues as follows.

It will remove empty line.

It will modify the translation by mistake.

Hi @linkinstar-sf , let us double-check that and come back to you

Hi @linkinstar-sf could you please try the following?
content = content.replace(/^#/g, '# ');

@Ira After that, It will be like this.

Sorry to bother you again. Please let me know if you have a new solution.

Hi @linkinstar-sf ,

I will check with the team

I would like to ask if there is a new solution? In the meantime, let me explain the reason for our persistence on this issue. Since our project is donated to apache, all files must carry the Apache License header description and be formatted correctly. So, I think there should be other open source projects that need this requirement as well. Many thanks to crowdin for helping to facilitate the translation of our open source project.

Hello @linkinstar-sf!

Sorry for the delay, we’re still investigating!

We’ll let you know as soon as there’s a solution.

1 Like

After your tip I solved the problem, by the way below.

content = content.replace(/^#/gm, '# ');
content = content.replace("#", "#\n#\n#");

The problem can be solved in this way for the present.