GitHub action fails - no sources found - had worked before

Error is:
“No sources found for ‘xxxxx’ pattern. Check the source paths in your configuration file”

This workflow worked fine until about 4 months ago, then started silently failing…


Our config file may be found here:

If there’s an error with no sources, than there’s something with sources. Maybe someone added a folder or something like that. Try double checking the path. Or fork the branch and try reproducing the issue to see where it is.

I had the same stuff in the past, and it was related to one of developers added a folder and didn’t inform others about it.

Yes, it was definitely an issue with the sources. We needed to alter base_path. Apparently how base_path works was altered in some way.

Once I got past that, however, a new problem appeared. We are working thru that at the moment.

We have two separate folders we use for staging app changes. The action always fails updating the second folder (the first folder is always OK) with a “You do not have permission to view/edit project with provided id.” error.

We are still working thru that error…

I have a ticket on the github-action repo over here:

These workflows have been running OK for the last two years, and started failing recently. It appears some backwards-incompatible changes went in earlier this year.

Interesting thing. I though that it’s something related to limits of account (you know, file extensions limit, or branches, or stuff like that), but now it looks like a different issue.

I saw in the git issue conversation Andrii from Crowdin replied you, do you tried that suggestion?

Yes, working thru the issues with Andrii. I’ve given them everything requested.

We are past the source errors, but now dealing with permissions-related errors.

Like peeling the layers of the onion…

Frustrating, because it has been working for the last two years.

But yes, Andrii is providing solid support.

Strange things may take place. Maybe some permission level update. Or extremely rare case that is hard to reproduce. I know few people using Git Actions and they works fine. Maybe they have simple repos and projects, but still, all works fine.

Just reviewed that conversation and it looks like Andrii already works on you issue. So I’m sure all should be fine there! Don’t give up!

p.s. Just from curiosity, have you tried like creating a small test project just from the scratch with a brand-new branch and repository? I’ve seen here a topic about Github and it has like a legacy-based problem, so fresh one helped to see that issue.

Closing the loop. Recreating the token in CrowdIn and the recreating the secret in GitHub got everything working again.

Not sure why we had to do that after running smoothly for 2 years, but it solved the permissions issue.

Thanks all!

1 Like

Glad to hear that the issue is solved now :slightly_smiling_face: