Downloaded translations don't match the current project configuration CLI error

Hi guys! We recently start using CLI and now I’m trying to download translations via CLI but the system gives me the follwoing error: Downloaded translations don’t match the current project configuration. The translations for the following sources will be omitted

The files structure in Crowdin and config looks the same

Can anyone tell me what I’m doing wrong?

1 Like

Hello! There is some mismatch in your files specified in the source/translations field in crowdin.yaml and the files in your actual project. We had the same error some time ago and in our case, the root cause of the issue was wrong export patterns.

We have export patter indicated in the translation field of crowdin.yaml but in our project the file export patterns were different. And that caused the mismatch.

We solved it in a simple way - just run the command crowdin push in order to update the export pattern of your source files. After that, the issue disappeared

1 Like