Crowdin overwrites translations on my name

Hi there.

I appears that I have changed the translations for Russian from my projects, overwriting the work of the contributors to the projects.

You can see the activity here: oinkoin Project Activity Stream

I have no idea from where the changes at 16:11 CET come from. If you see the history per sentence translated, you see that just 2 translations have been applied, the original, and the faulty one. I believe that the faulty one comes from some sort of automatic translation by crowdin.

See the image attached

1 Like

1 Like

Hi @emavgl.app,

It looks like translations were added to your project from the GitHub repository during sync. Since you connected integration, any activities related to integration will be always recorded under your name.

1 Like

Hi @sezoapp,

Maybe you are referring to New Crowdin updates by emavgl · Pull Request #65 · emavgl/oinkoin · GitHub - this PR contains indeed the faulty translations, but they originally come from Crowdin. I have merged the PR beliving they were translations from the contributors (since the commits always appear with my name).

1 Like

@emavgl.app

Looks like this merge pushed translations. You can undo it in 1 click in project activities.

1 Like

I clicked the Undo button at the end. But again, I surely did not commit the translations manually, so they come from some automatic part in Crowdin.

1 Like

When you connect the integration, “One-time translation import after the branch is connected” option is active by default, so existing translations will be imported after you connect integration for the first time or after you edit integration → click “Save”):

I don’t think it’s your case, but please check whether “Always import new translations from the repository” is deactivated in integration settings.

If your project has managers, probably someone triggered manual translations import (translations are uploaded from the name of the person who configured the sync):

1 Like

Hi.

In my integration-configurations, both options are enabled:

  • One-time translations import after the branch is connected
  • Always import new translations from the repository

I have Undo those changes but I think they got applied again

While I added the translations for German and Italian, I did not add any translations for Russian.

1 Like

In this case, I assume they are taken from the master branch: oinkoin/assets/locales/ru_RU.json at master · emavgl/oinkoin · GitHub

In this case, I of course want that new strings and translations are taken from the master branch and uploaded to Crodwin, however, I don’t want the old translations that you can find on the master branch, overwrite the updated translation done in Crowdin that are pending to be merged on master.

1 Like

Hi @emavgl.app!

You may try to disable the option “Always import new translations from the repository ” and then only the translations from Crowdin will be pushed to your repo. The translations from the repo will not overwrite the translations in Crowdin. Disabling the option will help to avoid such misunderstanding

Assuming I disable that option. That means that, if I add a new string on master, let’s say when I develop a new feature, this will not be added on Crowdin then. Am I right? This means that the two will be out of sync, which is not what I expect :frowning:

1 Like

Dear @emavgl.app !

Let me please explain a bit for you :wink:The integration with GitHub works the next way:

  1. If you only connect GitHub - both sources and translations from GitHub are synced to Crowdin

  2. Then after the first sync after the connection happened, automatically would be synced: source files from GitHub to Crowdin and translations from Crowdin to GitHub. So if you add the source string in your repo it will be automatically pushed to Crowdin and will be available for translation

  3. Other actions differ from those stated in point 2 would require additional options chosen. So if you’d like to sync source files from Crowdin to GitHub, it’s needed to choose the Push Sources option in the integration Settings. If you’d like to sync translations from GitHub to Crowdin, please use the Upload Translations option as my colleague described before.

Additional information about GitHub integration you may find here:

Hope this information will be useful for you!

1 Like

Ok, thanks for the explanation. I will try disabling the option:

  • Always import new translations from the repository

If I understood correctly, the source file (strings in en) will still stay in sync with master, and the translations only will be instead in the only direction Crowdin → Github.

With this, I’ll see if the problem arises again.

1 Like

Dear @emavgl.app !

Don’t worry the option Always import new translations from the repository will not affect the source files :wink:

Only the translations from your repo will not be automatically pushed to Crowdin. As you point out translations will move in this direction Crowdin → Github

2 Likes