Bug: Previously filled out segments disappear


I have the following issue: Both me and my co-worker worked on translations, which we didn’t save or approve yet, and when we went back to work on them, the input from the segments was gone.

In my co-worker’s case, the entire translation draft was lost, whereas in my case, only some segments (which had been previously filled out) were suddenly gone. Usually this is not the case. When I work on a translation, refresh the project in another tab, and then close it, the draft just stays in the editor and I can pick up where I left off, when I open it again.

Can you shed some light on this bug? Is there possibly an issue with your cloud?

Hi mneustadt,

It is the expected behavior. The added translations are not saved in the Crowdin Editor unless you press a ‘Save’ button.

Hope this sheds the light on the matter :slightly_smiling_face:

Hi Olena,

thanks for your swift reply! Okay, that resolves it. It was kind of confusing, because leaving a draft in the editor without saving it has worked so many times (and also works in other TMS).
Perhaps that is something you could add to your documentation?



Hi Mark,

Thank you for the suggestion. I will pass on this feedback to our Product team. There is room for improvement :blush: