Add File Error when use Gitlab Enterprise Intergration

Hi all, when i try to sync file from my gitlab repo to crowdin, i face a error :

Invalid options given : [exportPattern][exportPattern - Export pattern can’t contain any of the following characters: * ? : " < > |]

so path file to use for this upload is:

/[anhlv.Sigma Streaming Micro Frontend] main/packages/transcode/src/locales

it’ve [ and ] character, but i can’t change this, this is path default, generate from gitlab intergration

If anyone face error like that please give me a suggest. Very thanks.

Can you share the full crowdin.yml file here so I can see it and check?

By default it shouldnt create anything within […] - this thing is used in Crowdin UI only, in order for manager to see which repository branch belongs to, in case you use multi repo and all are named just “main”.

Probably would be better to delete the integration, delete crowdin.yaml, delete the branch from Crowdin, and re-setup everything just using integration editor in the user iterface. Once it’s done for the first time it should fulfill the yaml just fine and next time you can edit it safely.

More info VCS Integrations: Configuring Online | Crowdin Documentation

hi @VoldemarSamrani, here is my crowdin.yml

files:
  - source: packages/*/src/locales/vi.yaml
    translation: packages/*/src/locales/%two_letters_code%.%file_extension%

so, explain name “[anhlv.Sigma Streaming Micro Frontend] main”

  • anhlv: my gitlab username
  • Sigma Streaming Micro Frontend: is Project name
  • main: is branch what i’ve sync
    I just config crowdin.yml and click sync then this error happen, nothing uploaded

fully error:

Path starts without slash, it’s interesting, I guess there’s a need to add one like here Configuration File | Crowdin Developer Portal

But in overall I think that you need to delete old content from Crowdin, like duplicated branches, other not needed branches and so on if you have some, and just re setup the integration like @VoldemarSamrani said.

1 Like

I’ve re-setup the integration @VoldemarSamrani said. (delete everything and only use web interface to setup)

And config crowdin.yaml like that

files:
  - source: /packages/*/src/locales/vi.yaml
    translation: /packages/*/src/locales/%two_letters_code%.%file_extension%

but nothing change, this error still happen. Any suggest for this? @Alessandro_1two

Try using **
double asterisk instead 1

so it will look like

/packages//src/locales/vi.yaml
/translation: /packages/
/src/locales/%two_letters_code%.%file_extension%

  • add a buffer folder, dont store translation in the same way with orginal source

Like translation: /packages/testing/**/src/locales/%two_letters_code%.%file_extension%

1 Like

its worked, thanks you so much @GregoryLanncved

Had same issue, with ** it become solved, thank you @GregoryLanncved !